Go Back   CMP Forums > Marketplace > NM Collector CMP Edition Software
Register FAQ Members List Calendar Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 10-30-2016, 08:11 AM
Bwcritch Bwcritch is offline
 
Join Date: Jul 2012
Location: Mobile, Al
Posts: 1,617
Default Older version of Java won't install on MacBook, now cannot use program.

I'm throwing this on here for all to see partially to see if anyone else is having problems. Clay, if this is something new on your radar, which it may be, let me know what I can do to help come up with a solution.

So I downloaded and installed the iOS 10.12.1 Sierra the other day. This morning I opened up NM Collector to log my latest acquisition, but it will not let me open the program because a legacy version of Java needs to be installed. I was able to download the older version of Java, however when I went to install it, it will not let me install because a newer version is currently installed.

Is there something I can do so that NM Collector will run on the latest version of Java?
Reply With Quote
  #2  
Old 10-30-2016, 04:38 PM
Bwcritch Bwcritch is offline
 
Join Date: Jul 2012
Location: Mobile, Al
Posts: 1,617
Default

An update to my post earlier today.

I was able to get the older version of Java to install. I had to close all programs, and them restart my MacBook. This then allowed me to install the older version. My question/issue now, is what about other Java based programs that are on my computer? Though I have not ran in to any issues, what if I need to run a program that requires a newer version of Java? Am I going to have to choose to only use certain programs?
Reply With Quote
  #3  
Old 10-30-2016, 11:12 PM
nmCollector nmCollector is offline
 
Join Date: Dec 2009
Location: Albuquerque, New Mexico
Posts: 249
Question No need to install legacy version of Java

You should not have to install a legacy version of Java for NM Collector Software to run. It should work just fine with the latest Java. I run it with the latest Java on my windows computers.

However, I know in the past there have been some issues with Java configuration on Macs. Are you sure Java was configured properly on your Mac?

I googled this issue and found lots of people complaining about Sierra including some complaints about Java - however, the problems I have seen do not look like they would affect NM Collector and the recommendation for solving those problems seems to be to upgrade to the latest Java, not to downgrade. Here is an official support entry from Oracle: https://java.com/en/download/faq/sierra_java.xml

I would strongly suggest that you use the latest Java.

Thanks,
__________________
Clay Pryor
nmCollector.net LLC

Last edited by nmCollector; 10-30-2016 at 11:22 PM. Reason: found more info
Reply With Quote
  #4  
Old 10-31-2016, 08:10 AM
Bwcritch Bwcritch is offline
 
Join Date: Jul 2012
Location: Mobile, Al
Posts: 1,617
Default

Quote:
Originally Posted by nmCollector View Post
You should not have to install a legacy version of Java for NM Collector Software to run. It should work just fine with the latest Java. I run it with the latest Java on my windows computers.

However, I know in the past there have been some issues with Java configuration on Macs. Are you sure Java was configured properly on your Mac?

I googled this issue and found lots of people complaining about Sierra including some complaints about Java - however, the problems I have seen do not look like they would affect NM Collector and the recommendation for solving those problems seems to be to upgrade to the latest Java, not to downgrade. Here is an official support entry from Oracle: https://java.com/en/download/faq/sierra_java.xml

I would strongly suggest that you use the latest Java.

Thanks,
Clay,

So this is what I did this morning.

I first ran a report for the inventory, and printed it via a PDF, that way I had another quick reference, just in case.

I then installed the latest version of Java. I tried opening the program, and it said I again needed a legacy version. I then installed the legacy version, opened the program and it worked fine. I then tried to play a game on the computer (I enjoy playing bridge builder while on long airline flights, so I gave it a try), and it said my Java was out of date. So then I installed the newest version of Java, and tried NM Collector and my Bridge Builder game, and what do you know, everything works.

Clay, in all fairness there is note on the Java website that says that Sierra has been having issues. I don't think this is an issue with your program, but certainly frustrating since now everything is working, its hard to narrow down what the issue may have been.
Reply With Quote
  #5  
Old 10-31-2016, 12:52 PM
nmCollector nmCollector is offline
 
Join Date: Dec 2009
Location: Albuquerque, New Mexico
Posts: 249
Default

Thanks for your persistence and for posting the problem and a solution. Hopefully others will benefit.

Sent from my SM-G928P using Tapatalk
__________________
Clay Pryor
nmCollector.net LLC
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:41 PM.