Go Back   CMP Forums > CMP Sales > CMP 1911
Register FAQ Members List Calendar Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 01-16-2019, 02:54 PM
Jav8or Jav8or is offline
 
Join Date: Nov 2018
Location: New Mexico
Posts: 17
Default First Day of ownership, almost a great day...

Good day all,

New 1911 owner here.

Took the A1 out to the range. Over the course of 50 rounds, all went down the tube just fine, but about 30 rounds in, the slide would put lock back. Iím almost 100 percent sure itís a magazine issue, as I was able to replicate the problemwithnan empty mag repeatedly.

Then, when I got home, I discovered the hammer would drop while pulling the trigger, but not engaging the grip strap safety.
Any assistance would be appreciated.

Thanks all!
Reply With Quote
  #2  
Old 01-16-2019, 03:00 PM
Todd Todd is offline
 
Join Date: Dec 2009
Location: Talent OR
Posts: 89
Default

First problem I have heard with a cmp 1911
Reply With Quote
  #3  
Old 01-16-2019, 03:11 PM
Jav8or Jav8or is offline
 
Join Date: Nov 2018
Location: New Mexico
Posts: 17
Default

Precisely why I’m asking the group, just into ensure I didn’t do something boneheaded
Reply With Quote
  #4  
Old 01-16-2019, 03:18 PM
Jav8or Jav8or is offline
 
Join Date: Nov 2018
Location: New Mexico
Posts: 17
Default

Just put everything back together for the fifth time and now the safety seems to be working....

Could over lube cause that?
Reply With Quote
  #5  
Old 01-16-2019, 03:25 PM
utdutt utdutt is offline
 
Join Date: Jun 2010
Location: Alabama side of Fort Benning
Posts: 191
Default

Don't think over lubing would cause that, unless it was causing the grip safety to stick against the frame not allowing it to fully seat against the rear of the trigger. Before seeing that it now works, I was going to suggest the grip safety may be worn and not contacting the trigger properly, that or it's dirty or fouled, maybe sticking against the frame so not seating properly to stop the rearward action of the trigger. The grip safety should move freely and snap back into place after being depressed.
Reply With Quote
  #6  
Old 01-16-2019, 03:51 PM
Jav8or Jav8or is offline
 
Join Date: Nov 2018
Location: New Mexico
Posts: 17
Default

The grip safety has always snapped back.

I don’t know, maybe I didn’t reassemble correctly, but it’s working now. Same for the slide lock...
Reply With Quote
  #7  
Old 01-16-2019, 03:57 PM
utdutt utdutt is offline
 
Join Date: Jun 2010
Location: Alabama side of Fort Benning
Posts: 191
Default

Quote:
Originally Posted by Jav8or View Post
The grip safety has always snapped back.

I donít know, maybe I didnít reassemble correctly, but itís working now. Same for the slide lock...
Glad it's working! Didn't think CMP would let a faulty pistol get through. Did you detail strip the frame? If so, that may have been the problem, if you don't get all those internals just right you can have problems. I usually need an exploded schematics or youtube video when I put one back together.
Reply With Quote
  #8  
Old 01-16-2019, 04:00 PM
Jav8or Jav8or is offline
 
Join Date: Nov 2018
Location: New Mexico
Posts: 17
Default

It was just a field strip. I have been on the couch for about an hour try to spurt this thing to fail again....turning it upside down...light smacks on the butt.....it won’t fail again....?

As a former maintainer, this is the kind of stuff that makes me scratch my head.
Reply With Quote
  #9  
Old 01-16-2019, 04:03 PM
Texxut Texxut is offline
 
Join Date: Dec 2018
Posts: 11
Default

If this is the first 1911 you have owned, I suggest you read thru the manual they sent with the pistol, cover to cover a couple of times. Then, go thru the procedure to check the function and operation as outlined in the manual. It could be you just had it together wrong and now you have it correct.
Reply With Quote
  #10  
Old 01-16-2019, 04:04 PM
Jav8or Jav8or is offline
 
Join Date: Nov 2018
Location: New Mexico
Posts: 17
Default

Fair enough
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:29 AM.