Go Back   CMP Forums > CMP Sales > M1 Garand
Register FAQ Members List Calendar Mark Forums Read

Reply
 
Thread Tools Display Modes
  #11  
Old 12-17-2017, 10:24 PM
lapriester lapriester is offline
 
Join Date: Oct 2009
Location: Cobb, N California
Posts: 16,123
Exclamation

Then again, it could be one of the Italian ones that were being sold several years ago. The good part is that they were every bit as good as USGI mounts. You might try and contact Andy from Italy and ask him. I believe he was selling them back then.

andy ita.

Last edited by lapriester; 12-17-2017 at 10:28 PM.
Reply With Quote
  #12  
Old 12-18-2017, 10:32 PM
Twinson Twinson is online now
 
Join Date: Oct 2009
Location: IL
Posts: 1,360
Default

That is not a repro mount. These are all USGI mounts. The bottom three are unissued. You can see some minor differences in them. Two I can see where the threads almost poke thru the mount side, so it is totally possible that a bad casting was used on the one shown from the OP. Or it could be an early or late one. The repros up to this time have had cast marks that were seen on all repros in a certain spot if you know where to look. I do not see those casting marks on the OP's picture. Lets not forget that a number of companies made these for the US Gov't from time to time. Just look at the critical mounting surfaces and you will have your answer as to real or repro. Hope the pictures help..





Last edited by Twinson; 12-18-2017 at 11:19 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:40 PM.