Go Back   CMP Forums > CMP Sales > CMP 1911
Register FAQ Members List Calendar Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 06-13-2021, 12:56 AM
Dr. Spector Dr. Spector is offline
 
Join Date: Jul 2020
Location: Virginia
Posts: 8
Default Some functionality issues with my rack grade

Hi All,

Today I took my Rack Grade to the range for the first time, and while it was a blast to shoot I ran into a few problems. Occasionally I had a round that had issues going into battery. It mostly chambered, but I needed to remove the magazine and engage the slide before it was fully chambered. In addition, multiple times when I fired my last round the slide stop did not function. With an empty magazine, the slide still moved forward as if there was another round to chamber. When I got the 1911 I went through coolgunsite's function check and passed all their checks. Is this an issue with my magazine or do I need to ask the CMP armorers to take a peek at the gun?

Thank you,
LS
__________________
"It's an ok gun I guess" - Winston Churchill
Reply With Quote
  #2  
Old 06-13-2021, 03:12 AM
Fenris_Bane Fenris_Bane is offline
 
Join Date: Dec 2019
Posts: 267
Default

Quote:
Originally Posted by Dr. Spector View Post
Hi All,

Today I took my Rack Grade to the range for the first time, and while it was a blast to shoot I ran into a few problems. Occasionally I had a round that had issues going into battery. It mostly chambered, but I needed to remove the magazine and engage the slide before it was fully chambered. In addition, multiple times when I fired my last round the slide stop did not function. With an empty magazine, the slide still moved forward as if there was another round to chamber. When I got the 1911 I went through coolgunsite's function check and passed all their checks. Is this an issue with my magazine or do I need to ask the CMP armorers to take a peek at the gun?

Thank you,
LS
It could be that all of your problems may be related to your magazine. If have hear that some the Mecgar Magazines have issues. I've seen complaints about them having extra strong springs. This can prevent rounds from fully chambering due to excessive friction at the magazine lips because of spring tension. I also saw an unboxing video where the slide never stopped on the last round with a Mecgar Magazine. The man switched magazine and the problem went away.

At 4:10 he used the Mecgar Magazine. He complained about them being "stiff and hard to load" indicating a strong spring. And at 4:50, the slide does not lock back. At 8:27 he zooms in on the Mecgar marking on the magazine.

https://www.youtube.com/watch?v=Zr0Rst8vHWM&t=253s

I'd first try another magazine you know will work and see if it fixes your problem.
Reply With Quote
  #3  
Old 06-13-2021, 09:24 AM
Tothemax Tothemax is online now
 
Join Date: Sep 2016
Location: Billings, MT
Posts: 1,338
Default

Did you remove the slide and lubricate the gun? If not, I would try that first.

Like FB said, did you try a different mag?

How about different ammo?

Try these first and see what happens. If you still have issues, contact the cmp and send it back for repair.
Reply With Quote
  #4  
Old 06-13-2021, 11:58 AM
Craftsman Craftsman is offline
 
Join Date: Oct 2009
Location: South Florida
Posts: 7,405
Default

What ammo are you using, GI Ball spec is what they were designed to run on.
__________________
Grandfathers Dwight & Percy- Both WWI US Army, Tank Corps & Corps of Engineers
Uncle Colby- WWII US Army Infantry - European Theater / Battle of the Bulge
Dad - US Army Infantry, Stateside - 1954-1956

VFW Patriots Circle Member
NRA Life Member
PMRPC - CMP/GSM Rifle Match Chairman
GSM Master Instructor
Reply With Quote
  #5  
Old 06-15-2021, 04:53 AM
Ratmotortom Ratmotortom is offline
 
Join Date: Nov 2020
Posts: 27
Default

I would do as the others have suggested. First thing is to be sure the pistol is well lubed. Try different types of ammo and take several mags to the range. I love the old mags for show and tell but Wilson Combat mags work well for me for reliability. Let us know how ya come out !!!
Reply With Quote
  #6  
Old 06-15-2021, 01:27 PM
gap gap is online now
 
Join Date: Nov 2010
Location: Central Pennsylvania
Posts: 1,882
Default

Very likely the Magazine follower spring.
Reply With Quote
  #7  
Old 06-28-2021, 01:47 PM
MarkV MarkV is offline
 
Join Date: Oct 2009
Location: Port Clinton Ohio
Posts: 503
Default

All .45acp Ammo is not created equal and can cause problems. Also recently did a 1911 malfunctions trouble shoot for a fellow club member and determined the only problem to be shooter error / limp wristing.
Reply With Quote
  #8  
Old 06-28-2021, 10:37 PM
weimar_police weimar_police is offline
 
Join Date: Nov 2012
Location: Near Spokane, WA
Posts: 2,379
Default

As said above - I go to the range with 2-5 mags and when I was in the army, if a new mag gave me issues, we messed with it for a few minutes and threw it away if it caused problems (many checkpoint mags, most are great).
As an MP I carried and still have, Wilson mags

Lube it and try a couple mags
__________________
Edward Tinker - Co-Authors of Police Lugers & Simson Lugers - Veteran Bring Backs Vol 1-4
Reply With Quote
  #9  
Old 06-29-2021, 12:18 AM
Dr. Spector Dr. Spector is offline
 
Join Date: Jul 2020
Location: Virginia
Posts: 8
Default

I haven't had a chance to go to the range a second time, the 1911 is still burning a hole in my pocket. For the same reason, I'm stuck with my mecgar mag for the time being. For what it's worth, I was also unable to press down on the slide stop on an empty mag. Breaking in the spring with a dowel seems to have fixed that at least, it's stiff but works.

The ammo I was using was Federal 230 Grain.
__________________
"It's an ok gun I guess" - Winston Churchill
Reply With Quote
  #10  
Old 06-29-2021, 12:56 PM
sasquatch440 sasquatch440 is offline
 
Join Date: Jan 2019
Location: KY
Posts: 22
Default

You mention lubricating it, but did you completely strip and clean the pistol?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:28 AM.